SNMP RMON 网络监控技术

基本信息

  • 课程:网络管理(0C602)
  • 主题:Remote Network Monitoring (RMON)
  • 页数:25页
  • 来源:田浩然上传资料 / 课件

核心内容

RMON 组件

RMON(Remote Network Monitoring)远程网络监控:

  • 数据收集器(Data gatherer):物理设备
  • 数据分析器(Data analyzer):分析数据的处理器
  • 探针(Probe):部署在网络中的设备

RMON 拓扑结构

Remote FDDI LAN → Router with FDDI Probe → RMON → FDDI Backbone Network
                                                      ↓
Router ← Bridge ← Router ← NMS ← Ethernet ← Remote Token Ring LAN

RMON 优势

  1. 本地监控:在本地监视和分析,仅转发数据到管理站,减少网络负载
  2. 无需直接可见性:NMS无需直接连接到被监控段,获得更可靠信息
  3. 更频繁监控:允许更频繁的监控,从而更快故障诊断
  4. 提高管理效率:提升管理员生产力

RMON MIB 分组结构

RMON MIB(rmon = mib-2 16)分为三大类:

统计组(Statistics Groups)

  • rmon 1: Link level statistics(链路层统计)
  • rmon 2: Periodic statistical data collection(周期性数据统计)
  • rmon 4: Host statistics(主机统计)
  • rmon 5: Host Top N statistics(主机TOP N统计)
  • rmon 6: Matrix statistics(矩阵统计)
  • rmon 10: Token Ring statistics(令牌环统计)

事件报告组(Event Reporting Groups)

  • rmon 3: Alarm table(告警表)
  • rmon 9: Event generation(事件生成)

过滤器和包捕获组(Filter and Capture Groups)

  • rmon 7: Packet filtering(包过滤)
  • rmon 8: Packet capture(包捕获)

RMON1 vs RMON2

  • RMON1(RFC 1757):Layer 2 以太网/令牌环统计
  • RMON2(RFC 2021):Enhancements,Layer 3-7 协议分布、地址映射等
  • RMON1 Extension(RFC 1513):Token Ring扩展

RMON MIB 表结构

OID功能表
rmon 1链路层统计etherStatsTable, etherStats2Table
rmon 2周期统计收集和存储historyControlTable, etherHistoryTable
rmon 3阈值告警alarmTable
rmon 4主机统计数据hostControlTable, hostTable
rmon 5TOP N主机统计hostTopNcontrolTable

与其他知识关联